المساعد الشخصي الرقمي

مشاهدة النسخة كاملة : ترقيع pl1 للنسخة 3.7.4 !!!


MIDO-EGYPT
2008-12-12, 04:27 PM
بسم الله الرحمن الرحيم

هذا الترقيع يخص النسخة 3.7.4 وقد أعلنت الشركة اليوم صباحاً 21/11/2008 عن وجود ثغرة XSS
في لوحة تحكم العضو تخول الهاكر بالدخول لحسابات الأعضاء أو التعديل في بياناتهم..

المصدر:
http://www.vbulletin.com/forum/showthread.php?t=291665 (http://www.vbulletin.com/forum/showthread.php?t=291665)



الترقيع :
1- للأعضاء المرخصين توجه إلى الرابط التالي وقم بتحميل الباتش:
http://members.vbulletin.com/patches.php (http://members.vbulletin.com/patches.php)

2- للأعضاء الغير مرخصين بإمكانك التعديل على الملفات المصابة:
ملف واحد فقط وهو usercp.php افتح الملف بأي برنامج تحرير وابحث عن:

$visitormessage['summary'] = fetch_word_wrapped_string(fetch_censored_text(fetc h_trimmed_title(strip_bbcode($visitormessage['pagetext'], true, true), 50)));


استبدلها بـ:

$visitormessage['summary'] = htmlspecialchars_uni(fetch_word_wrapped_string(fet ch_censored_text(fetch_trimmed_title(strip_bbcode( $visitormessage['pagetext'], true, true), 50))));



للإفادة فقط التغيير الذي تم أنه أضيف htmlspecialchars_uni طبعاً هذه الـfunction تقوم بمنع المستخدم من استخدام الحروف الخاصة المتفق عليها دولياً مثل علامات التنصيص والأحرف مثل & والمسافة وما شابه .. وتقوم بتحويلها إلى & | " | ' ... إلخ أما uni فهو نوع جديد أكثر أمان تم إضافته للــfunction .. http://traidnt.net/vb/images/smilies/cupidarrow.gif


لتغيير رقم النسخ استبدل كامل محتويات الملف includes/version_vbulletin.php بـ:

<?php

define('FILE_VERSION_VBULLETIN', '3.7.4 Patch Level 1');

?>


مع تمنياتي لكم بالتوفيق
منقوووول

سمو المشآعر
2008-12-30, 02:40 AM
يعطيك العافيييييييه أخوي ميدوو


مبدع بمعنى الكلمه


لك ودي واحترامي يالغلا